RubyGems Navigation menu

activerecord-retry 1.0.0

Retries reads and transactions when an ActiveRecord::StatementInvalid occurs that matches a list of errors. Default list of errors includes errors related to failover situations to allow for graceful failovers during a request and to attempt prevention of data loss for temporary issue.

Gemfile
          gem 'activerecord-retry', '~> 1.0.0'
  
  
  
  
  
  
  

install
          gem install activerecord-retry
  
  
  
  
  
  
  

Total downloads 6,772

For this version 6,772

Required Ruby Version: None

Links:

Versions:

  1. 1.0.0 - September 6, 2012 (5 KB)