RubyGems Navigation menu

activerecord_constraints 0.1.1

This plugin currently implements constraints for PostgreSQL only. It should provide a structure for a more abstract implementation. Currently it implements foreign key constraints, unique constraints and check constraints. null and not null constraints would be easy to add but they may collide with preexisting Active Record code.

Gemfile
          gem 'activerecord_constraints', '~> 0.1.1'
  
  
  
  
  
  
  

install
          gem install activerecord_constraints
  
  
  
  
  
  
  

Authors:

  • Perry Smith

Owners:

Total downloads 10,531

For this version 5,265

Required Ruby Version: None

Links:

Versions:

  1. 0.1.1 - May 19, 2012 (26 KB)
  2. 0.1.0 - May 19, 2012 (26 KB)