RubyGems Navigation menu

analizaruptor 0.3.1

Analizaruptor is a tool that looks for 'break', 'require', and 'provides' commands (and does a *teensy* bit of code analyzing (+/(class|module) *(w+)/+) to provide some defaults) to make your RubyMotion +Rakefile+ and +debugger_cmds+ files short and consistent. To use, include this gem, and add +app.analyze+ to your +Rakefile+, after you have added your libraries and whatnot. In your source code you can add Analizaruptor commands (+#----> break|provides|requires+) and those will be translated into directives for `app.files_dependencies` and `debugger_cmds`. Run +rake+ or +rake debug=1+, and off you go!

Gemfile
          gem 'analizaruptor', '~> 0.3.1'
  
  
  
  
  
  
  

install
          gem install analizaruptor
  
  
  
  
  
  
  

Authors:

  • Colin Thomas-Arnold <colinta@gmail.com>

Owners:

Total downloads 4,388

For this version 1,043

Required Ruby Version: None

Links:

Versions:

  1. 0.3.1 - March 7, 2013 (6 KB)
  2. 0.3.0 - December 7, 2012 (6 KB)
  3. 0.2.0 - December 3, 2012 (6 KB)
  4. 0.1.0 - October 31, 2012 (5.5 KB)