RubyGems Navigation menu

atoulme-Antwrap 0.7.4-java

A Ruby module that wraps the Apache Ant build tool. Antwrap can be used to invoke Ant Tasks from a Ruby or a JRuby script.

FEATURES/PROBLEMS:

Antwrap runs on the native Ruby interpreter via the RJB (Ruby Java Bridge gem) and on the JRuby interpreter. Antwrap is compatible with Ant versions 1.5.4, 1.6.5 and 1.7.0. For more information, see the Project Info (rubyforge.org/projects/antwrap/) page.

SYNOPSIS:

Antwrap is a Ruby library that can be used to invoke Ant tasks. It is being used in the Buildr (incubator.apache.org/buildr/) project to execute Ant (ant.apache.org/) tasks in a Java project. If you are tired of fighting with Ant or Maven XML files in your Java project, take some time to check out Buildr!

Gemfile
          gem 'atoulme-Antwrap', '~> 0.7.4'
  
  
  
  
  
  
  

install
          gem install atoulme-Antwrap -v 0.7.4
  
  
  
  
  
  
  

Authors:

  • Caleb Powell

Owners:

Total downloads 136,245

For this version 14,286

Show all versions (10 total)

Required Ruby Version: None

Links:

Versions:

  1. 0.7.5 - November 21, 2014 java (33.5 KB)
  2. 0.7.5 - November 21, 2014 (33.5 KB)
  3. 0.7.4 - December 12, 2012 (32.5 KB)
  4. 0.7.4 - December 12, 2012 java (32.5 KB)
  5. 0.7.3 - November 12, 2012 java (32.5 KB)
Show all versions (10 total)

Development Dependencies: