RubyGems Navigation menu

commander 4.1.6

The complete solution for Ruby command-line executables. Commander bridges the gap between other terminal related libraries you know and love (OptionParser, HighLine), while providing many new features, and an elegant API.

Versions:

  1. 4.2.1 - September 29, 2014 (32.5 KB)
  2. 4.2.0 - April 30, 2014 (32.5 KB)
  3. 4.1.6 - February 11, 2014 (31.5 KB)
  4. 4.1.5 - August 11, 2013 (30 KB)
  5. 4.1.4 - July 21, 2013 (30 KB)
Show all versions (18 total)

Runtime Dependencies:

Authors:

  • TJ Holowaychuk, Gabriel Gilder

Owners:

F1e3ab214a976a39cfd713bc93deb10f35a2cccac0a002d15f5062b3b1840180

Total downloads 916,450

For this version 169,620

Show all versions (18 total)

Required Ruby Version: None

Licenses:

MIT

Gemfile:
gem 'commander', '~> 4.1.6' = Copy to clipboard Copied!

install:
gem install commander -v 4.1.6 = Copy to clipboard Copied!

Links: