RubyGems Navigation menu

coral 0.5.0

coral

This gem is simply a meta package that installs and requires the CORL gem.

Note: CORL is still early in development!

DO NOT USE IN PRODUCTION YET!!

Now you get to hear the story of two names.

Short story first; We switched to the CORL name (github.com/coralnexus/corl).

If your interested in why:

The original name of the CORL project was Coral, and we were exited when we found the Ruby gem name “coral” available. Our first versions of our CORL system were named coral_core, coral_cloud, coral_vagrant, coral_plan, and many more were planned. We created a meta gem (this one) to install a core combination of gems.

During the course of development we found another project that came before ours that uses the name coral, so we decided to update our project name, so as to avoid conflicts.

For us Coral is more than a word, it is a concept that embodies dynamic ecosystems supporting a rich variety of lifeforms. Coral are very interesting creatures and we endeavor to create software that helps build dynamic ecosystems of digital creatures.

We decided to use an acronym that sounds like the word Coral because the acronym fit with our desire to create something good for administration but also good for flexible research, so we came to Cluster Orchestration and Research Library. We split the core components out into a small concurrent plugin framework called Nucleon, upon which CORL is built. All of our coral sub gems are integrated into these two.

This gem exists only as a installer for people who accidentally spell coral the right way when trying to install the CORL system. Use the CORL gem instead.

Licensed under Apache license, version 2. See LICENSE.txt for further details.

Copyright © 2013-2014 Adrian Webb <adrian.webb@coralnexus.com> Coral Technology Group LLC

Gemfile
          gem 'coral', '~> 0.5.0'
  
  
  
  
  
  
  

install
          gem install coral
  
  
  
  
  
  
  

Authors:

  • Adrian Webb

Owners:

Licenses:

  • Apache License, Version 2.0

Total downloads 1,201

For this version 202

Required Ruby Version: >= 1.9.1

Links:

Versions:

  1. 0.5.0 - August 25, 2014 (13.5 KB)
  2. 0.1.1 - February 8, 2013 (18.5 KB)

Runtime Dependencies: