RubyGems.org

Contains make configuration changes since this thing is a bitch to compile correclty. This library generates and parses Universally Unique Identifier (UUID), based on OSSP uuid C library. So, libossp-uuid library is pre-required. OSSP uuid (http://www.ossp.org/pkg/lib/uuid/) is a ISO-C:1999 application programming interface (API) for the generation of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant UUID. It supports DCE 1.1 variant UUIDs of version 1 (time and node based), version 3 (name based, MD5), version 4 (random number based) and version 5 (name based, SHA-1).

installgem install dudemeister-uuid4r
Authors

Daigo Moriwaki, Stefan Kaes, Ali Jelveh

4,062 total downloads 2,583 for this version
Owners

31ffebead0a2006305c6ce4a78c4888e

Gemfile
gem 'dudemeister-uuid4r', '~> 0.1.3'
Versions
  1. 0.1.3 November 9, 2010 (7.5 KB)
  2. 0.1.2 November 8, 2010 (7 KB)
Show all versions (3 total)