RubyGems Navigation menu

equatable 0.5.0

Allows ruby objects to implement equality comparison and inspection methods. By including this module, a class indicates that its instances have explicit general contracts for `hash`, `==` and `eql?` methods.

Gemfile
          gem 'equatable', '~> 0.5.0'
  
  
  
  
  
  
  

install
          gem install equatable
  
  
  
  
  
  
  

Total downloads 3,107

For this version 561

Required Ruby Version: >= 0

Links:

Versions:

  1. 0.5.0 - September 13, 2014 (10 KB)
  2. 0.4.0 - August 15, 2014 (9 KB)
  3. 0.3.0 - June 3, 2013 (8.5 KB)
  4. 0.2.0 - April 28, 2013 (8 KB)
  5. 0.1.0 - December 9, 2012 (8 KB)

Development Dependencies: