RubyGems.org

expectations

1.2.0

A lightweight unit testing framework. Tests (expectations) will be written as follows expect 2 do 1 + 1 end expect NoMethodError do Object.invalid_method_call end.

installgem install expectations -v 1.2.0
Authors

Jay Fields

49,895 total downloads 1,538 for this version
Owners

454bd31c811ab511d9c993ec2b3e7d8219c0e42b8c0843c530d65fdecce7fca816f19ffa919d27e6c5989e31b039f943

Gemfile
gem 'expectations', '~> 1.2.0'
Versions
  1. 2.0.0 February 12, 2010 (14 KB)
  2. 1.2.1 April 21, 2009 (13.5 KB)
  3. 1.2.0 July 27, 2008 (13 KB)
  4. 1.1.0 July 23, 2008 (13 KB)
  5. 1.0.0 May 17, 2008 (13 KB)
Show all versions (30 total)
Runtime Dependencies
  1. mocha >= 0.5.5