RubyGems Navigation menu

ffi-ncurses 0.3.2

A wrapper for ncurses 5.x. Tested on Mac OS X 10.4 (Tiger) and Ubuntu 8.04 with ruby 1.8.6 using ruby-ffi (>= 0.2.0) and JRuby 1.1.6. The API is very much a transliteration of the C API rather than an attempt to provide an idiomatic Ruby object-oriented API. The intent is to provide a 'close to the metal' wrapper around the ncurses library upon which you can build your own abstractions. See the examples directory for real working examples.

Versions:

  1. 0.4.0 - September 25, 2011 (46.5 KB)
  2. 0.3.3 - February 24, 2009 (20.5 KB)
  3. 0.3.2 - February 22, 2009 (28.5 KB)
  4. 0.3.1 - February 16, 2009 (26.5 KB)
  5. 0.3.0 - February 15, 2009 (26.5 KB)

Runtime Dependencies:

Development Dependencies:

Authors:

  • Sean O'Halpin

Owners:

E1d641bfe4071a5413bac781f06d3fd1

Total downloads 45,037

For this version 3,101

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'ffi-ncurses', '~> 0.3.2' = Copy to clipboard Copied!

install:
gem install ffi-ncurses -v 0.3.2 = Copy to clipboard Copied!

Links: