RubyGems Navigation menu

flexconf 0.2.1

FlexConf is a simple configuration utility that does its job and gets out of your way. It reads settings from a hash or YAML file ('config.yml' by default) but allows overrides from a '*_local.yml' file and from environment variables. Settings can be read as indifferent hash values (config['foo'] or config[:foo]) or method calls (config.foo) with recursive nesting (config.foo.bar). The code is lightweight and fast with no additional dependencies.

Versions:

  1. 0.2.1 - November 6, 2011 (15.5 KB)
  2. 0.2.0 - November 4, 2011 (15.5 KB)
  3. 0.1.0 - October 28, 2011 (15 KB)

Development Dependencies:

Authors:

  • Stephen Eley

Owners:

994e42bda994be2cd1d791f18ee6d561

Total downloads 3,803

For this version 1,427

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'flexconf', '~> 0.2.1' = Copy to clipboard Copied!

install:
gem install flexconf = Copy to clipboard Copied!

Links: