RubyGems.org

lesstile

1.1.0

Converts text formatted with an exceedingly simple markup language into valid HTML (iron clad guarantee!) - perfect for comments on your blog. Textile isn't good for this because not only does it do too much (do commenters really need subscript?), but it can also output invalid HTML (try a <b> tag over multiple lines...). Whitelisting HTML is another option, but you still need some sort of parsing if you want syntax highlighting. Integrates with CodeRay for sexy syntax highlighting.

installgem install lesstile
Authors

Xavier Shay

18,496 total downloads 2,269 for this version
Owners

4fa63505dd4dd4691b87d30508b1bfd3

Gemfile
gem 'lesstile', '~> 1.1.0'
Versions
  1. 1.1.0 September 15, 2010 (7 KB)
  2. 1.0.1 September 14, 2010 (7 KB)
  3. 1.0.0 September 14, 2010 (7 KB)
  4. 0.3 April 16, 2008 (6.5 KB)
  5. 0.3.0 October 27, 2009 (7 KB)
Show all versions (8 total)
Development Dependencies
  1. rspec ~> 2.11