RubyGems Navigation menu

literate_md 1.0.8

Literate programming using markdown! Converts files to html or extracts the code snippets into one or more source files. To use: $ literate_md --help Options: --weave, -w: Produce documentation --tangle, -t: Produce code --outputdir, -o <s>: Directory to write files to --lang, -l <s>: Default language of code (default: ruby) --files, -f <s>: Files to process --standalone, -s: Weaves in html and body tags --help, -h: Show this message

Gemfile
          gem 'literate_md', '~> 1.0.8'
  
  
  
  
  
  
  

install
          gem install literate_md
  
  
  
  
  
  
  

Authors:

  • remis

Owners:

Licenses:

  • The Apache Software License, Version 2.0

Total downloads 7,340

For this version 298

Show all versions (9 total)

Required Ruby Version: >= 0

Links:

Versions:

  1. 1.0.8 - April 27, 2014 (11 KB)
  2. 1.0.7 - February 21, 2013 (10 KB)
  3. 1.0.6 - February 21, 2013 (9.5 KB)
  4. 1.0.5 - June 22, 2012 (5.5 KB)
  5. 1.0.4 - March 24, 2012 (5.5 KB)
Show all versions (9 total)