RubyGems.org

mini_magick

1.2.1

- Why? I was using RMagick and loving it, but it was eating up huge amounts of memory. A simple script like this... Magick::read("image.jpg") do |f| f.write("manipulated.jpg") end ...would use over 100 Megs of Ram. On my local machine this wasn't a problem, but on my hosting server the ruby apps would crash because of their 100 Meg memory limit.

installgem install mini_magick -v 1.2.1
Authors

Corey Johnson

2,097,658 total downloads 1,326 for this version
Owners

Ad2c4ad6157960abb72c99a0c8d2eaeeA77873df3a9766b208e009248a2a9a5680643cc5c7a70d4cdddebc3185cd3c18

Gemfile
gem 'mini_magick', '~> 1.2.1'
Versions
  1. 3.8.0 July 22, 2014 (14 KB)
  2. 3.7.0 November 26, 2013 (13.5 KB)
  3. 3.6.0 May 21, 2013 (57.5 KB)
  4. 3.5.0 February 14, 2013 (54.5 KB)
  5. 3.4 December 28, 2011 (55 KB)
Show all versions (26 total)
Runtime Dependencies
  1. hoe >= 1.2.1