RubyGems Navigation menu

mockingbird 0.2.0

Mockingbird emulates the Twitter Streaming API using a simple script-like configuration that makes it easy to test code that connects to the Streaming API. Mockingbird can be used to simulate bad data, unexpected status codes, hard disconnects, etc. Mockingbird uses eventmachine to run as an actual streaming http server so it's a drop-in replacement for code that reads from the streaming api. Simply change the host and port your code is connecting to from Twitter to a running Mockingbird.

Versions:

  1. 0.2.0 - February 20, 2012 (10 KB)
  2. 0.1.1 - February 18, 2012 (9.5 KB)
  3. 0.1.0 - July 31, 2010 (9.5 KB)

Runtime Dependencies:

Authors:

  • Hayes Davis

Owners:

179ce9ac3fabbdca04fc875cfb4d40f6

Total downloads 5,683

For this version 2,574

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'mockingbird', '~> 0.2.0' = Copy to clipboard Copied!

install:
gem install mockingbird = Copy to clipboard Copied!

Links: