RubyGems Navigation menu

needle 1.1.0

Needle is a Dependency Injection/Inversion of Control container for Ruby. It supports both type-2 (setter) and type-3 (constructor) injection. It takes advantage of the dynamic nature of Ruby to provide a rich and flexible approach to injecting dependencies.

Gemfile
          gem 'needle', '~> 1.1.0'
  
  
  
  
  
  
  

install
          gem install needle -v 1.1.0
  
  
  
  
  
  
  

Total downloads 56,504

For this version 1,370

Show all versions (8 total)

Required Ruby Version: None

Links:

Versions:

  1. 1.3.0 - December 24, 2005 (635 KB)
  2. 1.2.1 - July 26, 2005 (634 KB)
  3. 1.2.0 - November 18, 2004 (123 KB)
  4. 1.1.0 - November 11, 2004 (118 KB)
  5. 1.0.0 - November 4, 2004 (114 KB)
Show all versions (8 total)