RubyGems Navigation menu

nokogiri-xmlsec 0.0.4

Adds support to Ruby for encrypting, decrypting, signing and validating the signatures of XML documents, according to the [XML Encryption Syntax and Processing](http://www.w3.org/TR/xmlenc-core/) standard, by wrapping around the [xmlsec](http://www.aleksey.com/xmlsec) C library and adding relevant methods to `Nokogiri::XML::Document`.

Versions:

  1. 0.0.4 - June 27, 2013 (20 KB)
  2. 0.0.3 - May 28, 2013 (19.5 KB)
Show all versions (4 total)

Runtime Dependencies:

Authors:

  • Colin MacKenzie IV

Owners:

5d8c7a8d951a28e10bd7407f33df6d63

Total downloads 1,484

For this version 883

Show all versions (4 total)

Required Ruby Version: None

Licenses:

MIT

Gemfile:
gem 'nokogiri-xmlsec', '~> 0.0.4' = Copy to clipboard Copied!

install:
gem install nokogiri-xmlsec = Copy to clipboard Copied!

Links: