RubyGems Navigation menu

ofx-parser 1.0.2

DESCRIPTION: ofx-parser is a ruby library to parse a realistic subset of the lengthy OFX 1.x specification. == FEATURES/PROBLEMS: * Reads OFX responses - i.e. those downloaded from financial institutions and puts it into a usable object graph. * Supports the 3 main message sets: banking, credit card and investment accounts, as well as the required 'sign on' set. * Knows about SIC codes - if your institution provides them. See www.eeoc.gov/stats/jobpat/siccodes.html * Monetary amounts can be retrieved either as a raw string, or in pennies. * Supports OFX timestamps.

Gemfile
          gem 'ofx-parser', '~> 1.0.2'
  
  
  
  
  
  
  

install
          gem install ofx-parser -v 1.0.2
  
  
  
  
  
  
  

Authors:

  • Andrew A. Smith

Owners:

Total downloads 12,887

For this version 2,552

Required Ruby Version: None

Links:

Versions:

  1. 1.1.0 - December 12, 2011 (22 KB)
  2. 1.0.2 - May 12, 2008 (22.5 KB)
  3. 1.0.1 - July 2, 2007 (29.5 KB)
  4. 1.0.0 - June 26, 2007 (29 KB)

Runtime Dependencies: