RubyGems.org

Plugin for the omnifocus gem to provide synchronization with Redmine Issues. This plugin uses the Redmine REST API. It must be enabled by an administrator for the plugin to work. The first time this runs it creates a yaml file in your home directory for the configuration data. * redmine_url is required. This is the base url for the redmine repository. * user_id is required. To find your user id login and go to the my account page. Your user_id is the number at the end of the url for my account. * username is optional. It is used if the redmine server requires authentication. * password is optional. It is used if the redmine server requires authentication. * queries is optional. It is used for custom queries or multiple queries. The queries config is an array of strings. The strings will be appended to a query of the form: "http://redmine_url/issues.xml?assigned_to_id=user_id" * just_project is optional. It is used to configure how to name the omnifocus projects used for issues. If just_project is true each redmine project will correspond to an omnifocus project. If it is false the omnifocus projects will be name with redmine_project-redmine_component. Example: --- user_id: 20 redmine_url: http://redmine/ username: me password: 1234 queries: ["status_id=1", "status_id=2"] just_project: false

installgem install omnifocus-redmine -v 1.2.4
Authors

aja

9,403 total downloads 982 for this version
Owners

5a837592409354297424994e8d62f722Ff9072f60e25730674ad0d18a140ff65

Gemfile
gem 'omnifocus-redmine', '~> 1.2.4'
Versions
  1. 1.2.6 July 18, 2014 (11.5 KB)
  2. 1.2.5 July 24, 2013 (9.5 KB)
  3. 1.2.4 May 1, 2012 (6.5 KB)
  4. 1.2.3 August 16, 2011 (6.5 KB)
  5. 1.2.2 August 3, 2011 (6.5 KB)
Show all versions (10 total)
Runtime Dependencies
  1. omnifocus ~> 1.4
Development Dependencies
  1. hoe ~> 2.12
  2. minitest >= 2.5.1