RubyGems Navigation menu

oyster 0.9.1

Oyster is a command-line input parser that doesn't hate you. It provides a simple API that you use to write a spec for the user interface to your program, and it handles mapping the input to a hash for you. It supports both long and short option names, subcommands, and various types of input data.

Versions:

  1. 0.9.5 - July 19, 2011 (11.5 KB)
  2. 0.9.4 - June 7, 2010 (11.5 KB)
  3. 0.9.3 - September 23, 2009 (11.5 KB)
  4. 0.9.2 - June 18, 2009 (11.5 KB)
  5. 0.9.1 - January 30, 2009 (11 KB)
Show all versions (6 total)

Runtime Dependencies:

Development Dependencies:

Authors:

  • James Coglan

Owners:

81eec7f220df03d5b8cadf106a2c14c5

Total downloads 29,617

For this version 1,472

Show all versions (6 total)

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'oyster', '~> 0.9.1' = Copy to clipboard Copied!

install:
gem install oyster -v 0.9.1 = Copy to clipboard Copied!

Links: