RubyGems Navigation menu

sequel_pg 1.6.11

sequel_pg overwrites the inner loop of the Sequel postgres adapter row fetching code with a C version. The C version is significantly faster (2-6x) than the pure ruby version that Sequel uses by default. sequel_pg also offers optimized versions of some dataset methods, as well as adds support for using PostgreSQL streaming.

Versions:

  1. 1.6.11 - November 4, 2014 (18.5 KB)
  2. 1.6.10 - July 11, 2014 x86-mswin32-60 (1.25 MB)
  3. 1.6.10 - July 11, 2014 x86-mingw32 (1.25 MB)
  4. 1.6.10 - July 11, 2014 (18 KB)
  5. 1.6.9 - March 5, 2014 x86-mswin32-60 (1.25 MB)
Show all versions (60 total)

Runtime Dependencies:

Authors:

  • Jeremy Evans

Owners:

F183bcc4176b308c9edabe79299e448f

Total downloads 97,992

For this version 2,041

Show all versions (60 total)

Required Ruby Version: >= 1.8.7

Licenses:

MIT

Gemfile:
gem 'sequel_pg', '~> 1.6.11' = Copy to clipboard Copied!

install:
gem install sequel_pg = Copy to clipboard Copied!

Links: