RubyGems Navigation menu

zbatery 4.2.0

Zbatery is an HTTP server for Rack applications on systems that either do not support fork(), or have no memory (nor need) to run the master/worker model. It is based on Rainbows! (which is based on Unicorn (which is based on Mongrel)) and inherits parts of each. Zbatery supports your choice of all the thread/fiber/event/actor-based concurrency models and Rack middleware that Rainbows! supports (or will ever support) in a single process.

Gemfile
          gem 'zbatery', '~> 4.2.0'
  
  
  
  
  
  
  

install
          gem install zbatery
  
  
  
  
  
  
  

Licenses:

  • GPLv2+, Ruby

Total downloads 24,184

For this version 410

Show all versions (20 total)

Required Ruby Version: >= 0

Links:

Versions:

  1. 4.2.0 - May 14, 2014 (57.5 KB)
  2. 4.1.2 - December 5, 2011 (56 KB)
  3. 4.1.1.2.g3693 - December 3, 2011 (55.5 KB)
  4. 4.1.1 - September 2, 2011 (55 KB)
  5. 4.1.0 - August 20, 2011 (54.5 KB)
Show all versions (20 total)

Runtime Dependencies:

Development Dependencies: