RubyGems Navigation menu

activefacts-api 1.9.9

The ActiveFacts API is a Ruby DSL for managing constellations of elementary facts. Each fact is either existential (a value or an entity), characteristic (boolean) or binary relational (A rel B). Relational facts are consistently co-referenced, so you can traverse them efficiently in any direction. Each constellation maintains constraints over the fact population.

Versions:

  1. 1.9.12 - February 12, 2018 (34 KB)
  2. 1.9.11 - August 02, 2016 (34 KB)
  3. 1.9.10 - May 25, 2016 (34 KB)
  4. 1.9.9 - April 08, 2016 (34 KB)
  5. 1.9.8 - March 22, 2016 (34 KB)
Show all versions (36 total)

Runtime Dependencies (2):

  • rbtree-pure >= 0.1.1, ~> 0
  • tracing >= 2.0.4, ~> 2
  • Development Dependencies (3):

  • bundler >= 1.10
  • rake ~> 10.0
  • rspec ~> 3.3
  • Owners:

    Authors:

    • Clifford Heath

    SHA 256 checksum:

    dc787d11d178e69127b9f4051e668adc1e6100e291244285046f3c3a6f1c9824

    Total downloads 116,134

    For this version 2,344

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: