RubyGems Navigation menu

fig 0.1.32

Fig is a utility for configuring environments and managing dependencies across a team of developers. You give it a list of packages and a shell command to run; it creates an environment that includes those packages, then executes the shell command in it (the caller's environment is not affected).

Versions:

  1. 1.27.10 - August 01, 2018 (104 KB)
  2. 1.27.8 - June 18, 2018 (104 KB)
  3. 1.27.5 - June 07, 2018 (104 KB)
  4. 1.27.4 - May 16, 2018 (104 KB)
  5. 1.27.3 - May 16, 2018 (104 KB)
  6. 0.1.32 - June 01, 2011 (20.5 KB)
Show all versions (160 total)

Runtime Dependencies (6):

  • highline >= 1.6.2
  • libarchive >= 0.1.1
  • net-netrc >= 0.2.2
  • net-ssh >= 2.0.15
  • polyglot >= 0.2.9
  • treetop >= 1.4.2
  • Development Dependencies (2):

  • open4 >= 1.0.1
  • rspec ~> 1.3
  • Owners:

    Authors:

    • Matthew Foemmel

    SHA 256 checksum:

    4969f59e4e71b0037cc55eb64f253a83105fa1c51697d9d0e1398689b8901478

    Total downloads 250,140

    For this version 2,350

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: None

    Links: