RubyGems Navigation menu

fig 0.1.55

Fig is a utility for configuring environments and managing dependencies across a team of developers. Given a list of packages and a command to run, Fig builds environment variables named in those packages (e.g., CLASSPATH), then executes the command in that environment. The caller's environment is not affected.

Versionen:

  1. 1.27.10 - August 01, 2018 (104 KB)
  2. 1.27.8 - June 18, 2018 (104 KB)
  3. 1.27.5 - June 07, 2018 (104 KB)
  4. 1.27.4 - May 16, 2018 (104 KB)
  5. 1.27.3 - May 16, 2018 (104 KB)
  6. 0.1.55 - January 25, 2012 (36,5 KB)
Zeige alle Versionen (160 total)

Runtime Abhängigkeiten (22):

  • ftp >= 0.69
  • ftp >= 0.69
  • highline >= 1.6.2
  • highline >= 1.6.2
  • json >= 1.6.5
  • json >= 1.6.5
  • libarchive-static >= 1.0.0
  • libarchive-static >= 1.0.0
  • log4r >= 1.1.5
  • log4r >= 1.1.5
  • net-netrc >= 0.2.2
  • net-netrc >= 0.2.2
  • net-sftp >= 2.0.4
  • net-sftp >= 2.0.4
  • net-ssh >= 2.0.15
  • net-ssh >= 2.0.15
  • polyglot >= 0.2.9
  • polyglot >= 0.2.9
  • rdoc >= 3.12
  • rdoc >= 3.12
  • treetop >= 1.4.2
  • treetop >= 1.4.2
  • Development Abhängigkeiten (6):

  • libarchive-static >= 1.0.0
  • libarchive-static >= 1.0.0
  • open4 >= 1.0.1
  • open4 >= 1.0.1
  • rspec >= 2.8
  • rspec >= 2.8
  • Besitzer:

    Autoren:

    • Matthew Foemmel

    SHA 256-Prüfsumme:

    c617bbd7903bc85d77231b391ddea6ed9978994a30096995a5dfd8bb92332b67

    Downloads insgesamt 250.400

    Für diese Version 2.337

    Gemfile:
    = In die Zwischenablage kopieren Kopiert!

    installieren:
    =

    Lizenzs:

    k.A.

    Erforderliche Ruby-Version: None

    Links: