RubyGems Navigation menu

mono_logger 1.0.0

A lock-free logger compatible with Ruby 2.0. Ruby does not allow you to request a lock in a trap handler because that could deadlock, so Logger is not sufficient.

Versions:

  1. 1.1.0 - May 19, 2013 (10 KB)
  2. 1.0.1 - April 08, 2013 (7 KB)
  3. 1.0.0 - March 20, 2013 (9.5 KB)

Development Dependencies (2):

  • bundler ~> 1.3
  • rake >= 0
  • Owners:

    Authors:

    • Steve Klabnik

    SHA 256 checksum:

    1859abb040614c17046202d6d789b17de993f295b4f2e1a2a1f8709f48e843df

    Total downloads 22,044,440

    For this version 126,542

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    ASL

    Required Ruby Version: None

    Links: