RubyGems Navigation menu

pact_broker 2.86.0

A server that stores and returns pact files generated by the pact gem. It enables head/prod cross testing of the consumer and provider projects.

Versions:

  1. 2.92.0 - November 27, 2021 (1.92 MB)
  2. 2.91.0 - November 15, 2021 (1.92 MB)
  3. 2.90.0 - November 12, 2021 (1.92 MB)
  4. 2.89.1 - October 27, 2021 (2.17 MB)
  5. 2.89.0 - October 15, 2021 (2.17 MB)
  6. 2.86.0 - September 17, 2021 (2.15 MB)
Show all versions (192 total)

Runtime Dependencies (25):

  • anyway_config ~> 2.1
  • dry-configurable = 0.12.1
  • dry-logic = 0.4.2
  • dry-types ~> 0.10.3
  • dry-validation ~> 0.10.5
  • haml ~> 5.0
  • httparty ~> 0.14
  • json ~> 2.3
  • pact-support ~> 1.16, >= 1.16.4
  • padrino-core >= 0.14.3, ~> 0.14
  • rack >= 2.2.3, ~> 2.2
  • rack-protection >= 2.0.8.1, < 3.0
  • redcarpet >= 3.5.1, ~> 3.5
  • reform ~> 2.3.3
  • request_store ~> 1.5
  • roar ~> 1.1
  • sanitize >= 5.2.1, ~> 5.2
  • semantic_logger ~> 4.3
  • semver2 ~> 3.4.2
  • sequel ~> 5.28
  • sinatra >= 2.0.8.1, < 3.0
  • sucker_punch ~> 2.0
  • table_print ~> 1.5
  • webmachine = 1.6.0
  • wisper ~> 2.0
  • Owners:

    Pushed by:

    Authors:

    • Bethany Skurrie, Sergei Matheson, Warner Godfrey

    SHA 256 checksum:

    056dd0496bdc21a71b7c9c98057e900843e78cb41d8eefc02b62bb87febf5740

    Total downloads 229,511

    For this version 636

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.2.0

    Links: