RubyGems Navigation menu

Reverse dependencies for punchblock 2.7.5