RubyGems Navigation menu

pwntools 1.2.1

Rewrite https://github.com/Gallopsled/pwntools in ruby. Implement useful/easy functions first, try to be of ruby style and don't follow original pwntools everywhere. Would still try to have similar name whenever possible.

Versiones:

  1. 1.2.1 - March 21, 2021 (2,09 MB)
  2. 1.2.0 - August 07, 2020 (2,09 MB)
  3. 1.1.0 - August 26, 2018 (2,09 MB)
  4. 1.0.1 - November 02, 2017 (2,08 MB)
  5. 1.0.0 - October 17, 2017 (1,71 MB)
Mostrar todas las versiones (6 total)

dependencias de Runtime (9):

  • crabstone ~> 4
  • dentaku >= 2.0.11, < 3.5.0
  • elftools >= 1.0.1, < 1.2.0
  • keystone-engine ~> 0.9
  • method_source >= 0.9
  • one_gadget >= 1.6.2, < 1.8.0
  • rainbow >= 2.2, < 4.0
  • ruby2ruby ~> 2.4
  • rubyserial ~> 0.5
  • dependencias de Development (7):

  • minitest = 5.10.1
  • pry ~> 0.10
  • rake ~> 13.0
  • rubocop ~> 1
  • simplecov ~> 0.15, < 0.18
  • tty-platform ~> 0.1
  • yard ~> 0.9
  • Propietarios:

    Subida por:

    Autores:

    • peter50216@gmail.com, david942j@gmail.com, hanhan0912@gmail.com

    SHA 256 checksum:

    cd4a8fe3b055488d1ce69f53788464bca24b22ca41fea9c1a68f7bfb181dac5f

    Total de descargas 9.565

    Para esta versión 2.104

    Gemfile:
    = Copiar al portapapeles ¡Copiado!

    instalar:
    =

    Licencia:

    MIT

    Versión de Ruby requerida: >= 2.3

    Enlace: