RubyGems Navigation menu

pwntools 1.2.1

Rewrite https://github.com/Gallopsled/pwntools in ruby. Implement useful/easy functions first, try to be of ruby style and don't follow original pwntools everywhere. Would still try to have similar name whenever possible.

バージョン履歴:

  1. 1.2.1 - March 21, 2021 (2.09MB)
  2. 1.2.0 - August 07, 2020 (2.09MB)
  3. 1.1.0 - August 26, 2018 (2.09MB)
  4. 1.0.1 - November 02, 2017 (2.08MB)
  5. 1.0.0 - October 17, 2017 (1.71MB)
全てのバージョンを表示 (全6項目)

Runtime依存性 (9):

  • crabstone ~> 4
  • dentaku >= 2.0.11, < 3.5.0
  • elftools >= 1.0.1, < 1.2.0
  • keystone-engine ~> 0.9
  • method_source >= 0.9
  • one_gadget >= 1.6.2, < 1.8.0
  • rainbow >= 2.2, < 4.0
  • ruby2ruby ~> 2.4
  • rubyserial ~> 0.5
  • Development依存性 (7):

  • minitest = 5.10.1
  • pry ~> 0.10
  • rake ~> 13.0
  • rubocop ~> 1
  • simplecov ~> 0.15, < 0.18
  • tty-platform ~> 0.1
  • yard ~> 0.9
  • オーナー:

    Pushed by:

    作者:

    • peter50216@gmail.com, david942j@gmail.com, hanhan0912@gmail.com

    SHA 256チェックサム:

    cd4a8fe3b055488d1ce69f53788464bca24b22ca41fea9c1a68f7bfb181dac5f

    累計ダウンロード数 9,565

    このバージョンのみ 2,104

    Gemfile:
    = クリップボードにコピー コピー完了!

    インストール:
    =

    ライセンス:

    MIT

    必要Rubyバージョン: >= 2.3

    リンク: