RubyGems Navigation menu

reverse-require 0.3.1

reverse-require allows one to require files that ends with a specified path from other RubyGems. For instance, if one wanted to require the file 'mylibrary/extensions.rb' from all RubyGems: require 'reverse_require' require_all 'mylibrary/extensions' # => true One can also require 'mylibrary/extensions.rb' only from RubyGems that depend on the currently loaded version of the mylibrary Gem: require_for 'mylibrary', 'mylibrary/extensions' # => true

Versions:

  1. 0.3.1 - January 8, 2009 (6 KB)
  2. 0.3.0 - January 8, 2009 (6 KB)
  3. 0.2.0 - November 23, 2008 (5.5 KB)
  4. 0.1.2 - October 22, 2008 (6 KB)
  5. 0.1.1 - October 5, 2008 (6 KB)
Show all versions (6 total)

Runtime Dependencies:

Development Dependencies:

Authors:

  • Postmodern

Owners:

66f5d5b64b951b3eeb8b6c34fcb69237

Sha 256 checksum:

093e84b43b80c4bfd94ef607811d4f2dbb8070dbab65df3226051537e5a89125

Total downloads 8,890

For this version 1,834

Show all versions (6 total)

Required Ruby Version: None

Licenses:

N/A

Gemfile:
= Copy to clipboard Copied!

install:
= Copy to clipboard Copied!

Links: