RubyGems Navigation menu

rubocop 0.34.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.16.1 - June 09, 2021 (482 KB)
  2. 1.16.0 - June 01, 2021 (482 KB)
  3. 1.15.0 - May 17, 2021 (480 KB)
  4. 1.14.0 - May 05, 2021 (478 KB)
  5. 1.13.0 - April 20, 2021 (477 KB)
  6. 0.34.0 - September 05, 2015 (288 KB)
Show all versions (179 total)

Runtime Dependencies (5):

  • astrolabe ~> 1.3
  • parser < 3.0, >= 2.2.2.5
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.4
  • Development Dependencies (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 3.2.0
  • simplecov ~> 0.10
  • yard ~> 0.8
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    e704f43bc99114ca93d78cef7937d5a7aebde105613bf82ec86612a8efb44bc3

    Total downloads 162,978,054

    For this version 58,366

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.3

    Links: