RubyGems Navigation menu

rubocop 0.34.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.8.1 - January 11, 2021 (459 KB)
  2. 1.8.0 - January 07, 2021 (459 KB)
  3. 1.7.0 - December 25, 2020 (456 KB)
  4. 1.6.1 - December 10, 2020 (451 KB)
  5. 1.6.0 - December 09, 2020 (451 KB)
  6. 0.34.1 - September 09, 2015 (289 KB)
Show all versions (168 total)

Runtime Dependencies (5):

  • astrolabe ~> 1.3
  • parser < 3.0, >= 2.2.2.5
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.4
  • Development Dependencies (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 3.2.0
  • simplecov ~> 0.10
  • yard ~> 0.8
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    0d904489dca12ab4005c358d74057e197266a2571c9feafc15a37bbe3c3b13f8

    Total downloads 136,594,429

    For this version 133,079

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.3

    Links: