RubyGems Navigation menu

rubocop 0.47.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.21.0 - September 13, 2021 (498 ko)
  2. 1.20.0 - August 26, 2021 (496 ko)
  3. 1.19.1 - August 19, 2021 (494 ko)
  4. 1.19.0 - August 12, 2021 (493 ko)
  5. 1.18.4 - July 23, 2021 (488 ko)
  6. 0.47.1 - January 18, 2017 (289 ko)
Voir toutes les versions (189)

Dépendances de Runtime (5):

  • parser < 3.0, >= 2.3.3.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Dépendances de Development (1):

  • bundler ~> 1.3
  • Propriétaires:

    Auteurs:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    Total de contrôle SHA 256:

    a7066a0c553e3bad1f118062deef5f05d050a6cf11cb9c9cda067b2a891a7916

    Total de téléchargements 182 152 245

    Pour cette version 3 037 240

    Gemfile:
    = Copier Copié!

    installation:
    =

    License:

    MIT

    Version de Ruby requise: >= 2.0.0

    Liens: