RubyGems Navigation menu

rubocop 1.18.1

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versões:

  1. 1.22.2 - October 22, 2021 (508 KB)
  2. 1.22.1 - October 04, 2021 (507 KB)
  3. 1.22.0 - September 29, 2021 (506 KB)
  4. 1.21.0 - September 13, 2021 (498 KB)
  5. 1.20.0 - August 26, 2021 (496 KB)
  6. 1.18.1 - June 30, 2021 (487 KB)
Mostrar todas as versões (192)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 3.0.0.0
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 0
  • rubocop-ast >= 1.7.0, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Donos:

    Pushed by:

    Autores:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    33ae45f78d826a5ef9613eebe354a841cee55eb02b826daa4ba7af1fb7d6689c

    Total de downloads 187.149.163

    Desta versão 151.391

    Gemfile:
    = Copy to clipboard Copied!

    instalar:
    =

    Licença:

    MIT

    Versão Requerida do Ruby: >= 2.5.0

    Links: