RubyGems Navigation menu

rubocop 1.9.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.12.1 - April 04, 2021 (477 KB)
  2. 1.12.0 - March 24, 2021 (476 KB)
  3. 1.11.0 - March 01, 2021 (473 KB)
  4. 1.10.0 - February 15, 2021 (469 KB)
  5. 1.9.1 - February 01, 2021 (467 KB)
  6. 1.9.0 - January 28, 2021 (466 KB)
Show all versions (174 total)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 3.0.0.0
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 0
  • rubocop-ast >= 1.2.0, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    a99ce92e7b5b2050b75a8885b1ca2a32f7c690222bba3357d566f4495ebee0f3

    Total downloads 153,167,154

    For this version 112,395

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.4.0

    Links: