RubyGems Navigation menu

active_interaction 5.3.0

ActiveInteraction manages application-specific business logic. It is an implementation of what are called service objects, interactors, or the command pattern. No matter what you call it, its built to work seamlessly with Rails.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 5.3.0 - May 06, 2023 (62 KB)
  2. 5.2.0 - October 22, 2022 (61.5 KB)
  3. 5.1.1 - September 01, 2022 (61.5 KB)
  4. 5.1.0 - July 28, 2022 (61.5 KB)
  5. 5.0.0 - June 24, 2022 (61 KB)
Show all versions (91 total)

Runtime Dependencies (2):

activemodel >= 5.2, < 8
activesupport >= 5.2, < 8

Development Dependencies (10):

actionpack >= 0
kramdown ~> 2.1
rake ~> 13.0
rspec ~> 3.5
rubocop ~> 1.26.1
rubocop-rake ~> 0.6.0
rubocop-rspec ~> 2.9.0
sqlite3 >= 0
yard ~> 0.9

Owners:

Pushed by:

Authors:

  • Aaron Lasseigne, Taylor Fausak

SHA 256 checksum:

d95b4cff976c75f9a5721305a1a015507e427c61120ad8cedfd891f42dd83b3e

Total downloads 3,635,432

For this version 309,594

License:

MIT

Required Ruby Version: >= 2.7

New versions require MFA: true

Version published with MFA: true

Links: