RubyGems Navigation menu

api_mini_tester 0.1.15

Runs automated REST API based on YAML definition. Uses templates for API requests, mock data with faker and cz_faker and context data. Supports Postman collection export for conversion.

Versions:

  1. 0.1.15 - March 18, 2019 (10.5 KB)
  2. 0.1.14 - February 12, 2019 (10 KB)
  3. 0.1.13 - January 09, 2019 (10 KB)
  4. 0.1.12 - December 28, 2018 (10 KB)
  5. 0.1.11 - November 20, 2018 (10 KB)
Show all versions (12 total)

Runtime Dependencies (7):

  • builder ~> 3.0, >= 3.0.4
  • cz_faker ~> 0.0.5, >= 0.0.5
  • distribution ~> 0.7, >= 0.7.3
  • faker ~> 1.8, >= 1.8.7
  • hash_parser ~> 0.0, >= 0.0.2
  • httparty ~> 0.16, >= 0.16.0
  • liquid ~> 4.0, >= 4.0.0
  • Development Dependencies (6):

  • minitest ~> 5.11, >= 5.11.3
  • minitest-reporters-json_reporter ~> 1.0, >= 1.0.0
  • nexus ~> 1.4, >= 1.4.0
  • rubocop ~> 0.58, >= 0.58.2
  • simplecov ~> 0.16, >= 0.16.1
  • webmock ~> 3.4, >= 3.4.2
  • Owners:

    Authors:

    • Jindrich Skupa (@eMan)

    SHA 256 checksum:

    ef11a5861773f7f3f5a62ef3fa94d846876adaddd8d75f26054392e5698234b2

    Total downloads 5,565

    For this version 818

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: