RubyGems Navigation menu

asciidoctor-include-ext 0.4.0

This is a reimplementation of the Asciidoctor's built-in (pre)processor for the include::[] directive in extensible and more clean way. It provides the same features, but you can easily adjust it or extend for your needs. For example, you can change how it loads included files or add another ways how to select portions of the document to include.

Versions:

  1. 0.4.0 - March 29, 2022 (11.5 KB)
  2. 0.3.1 - April 14, 2019 (11 KB)
  3. 0.3.0 - May 09, 2018 (11 KB)
  4. 0.2.0 - May 03, 2018 (11 KB)
  5. 0.1.1 - December 13, 2017 (11 KB)
Show all versions (6 total)

Runtime Dependencies (1):

  • asciidoctor >= 1.5.6, < 3.0.0
  • Development Dependencies (6):

  • kramdown ~> 2.0
  • rake ~> 13.0
  • rspec ~> 3.7
  • rubocop ~> 0.51.0
  • simplecov ~> 0.15
  • yard ~> 0.9
  • Owners:

    Pushed by:

    Authors:

    • Jakub Jirutka

    SHA 256 checksum:

    406adb9d2fbfc25536609ca13b787ed704dc06a4e49d6709b83f3bad578f7878

    Total downloads 12,370,364

    For this version 2,869,575

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.3

    Links: