RubyGems Navigation menu

autoloaded 2.2.1

If you like the ‘Module#autoload’ feature of the Ruby Core library, you may have wished for Autoloaded. It eliminates the drudgery of handcrafting an `autoload` statement for each Ruby source code file in your project. It also avoids the limitations of rigid convention-driven facilities such as those provided by the ActiveSupport RubyGem. Autoloaded assumes, but does not enforce, `CamelCase`-to-`snake_case` correspondence between the names of constants and source files. You can combine conventions, even putting multiple autoloaded constants in a single source file.

Versions:

  1. 2.2.1 - October 18, 2017 (20.5 KB)
  2. 2.2.0 - February 23, 2017 (20.5 KB)
  3. 2.1.1 - January 24, 2015 (28 KB)
  4. 2.0.0 - December 27, 2014 (28 KB)
  5. 1.5.1 - October 18, 2017 (22 KB)
Show all versions (16 total)

Authors:

  • Nils Jonsson

Owners:

SHA 256 checksum:

bd57b9d0a2d713f73ca8bee2f3b32e29487a53289dd0b577b3a021b494793a2e

Total downloads 32,175

For this version 7,093

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: < 3, >= 1.9

Links: