RubyGems Navigation menu

boxcars 0.4.9

You simply set an OpenAI key, give a number of Boxcars to a Train, and magic ensues when you run it.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 0.4.9 - January 25, 2024 (54.5 KB)
  2. 0.4.8 - January 08, 2024 (53.5 KB)
  3. 0.4.7 - November 07, 2023 (53.5 KB)
  4. 0.4.6 - November 06, 2023 (53.5 KB)
  5. 0.4.5 - October 06, 2023 (52 KB)
Show all versions (40 total)

Runtime Dependencies (7):

anthropic ~> 0.1
gpt4all ~> 0.0.4
hnswlib ~> 0.8
nokogiri ~> 1.16
pgvector ~> 0.2
ruby-openai >= 4.2, < 7.0

Owners:

Pushed by:

Authors:

  • Francis Sullivan, Tabrez Syed

SHA 256 checksum:

627b8f2596555bdbbdc157ce14d51a18f7adeac9c3bcd0fe79f1b95108c385e9

Total downloads 12,364

For this version 215

License:

MIT

Required Ruby Version: >= 3.0

New versions require MFA: true

Version published with MFA: true

Links: