RubyGems Navigation menu

chef-attribute-validator 0.9.0

Define, enforce, and handle violations of validation rules for Chef node attributes. This gem provides the validation engine, and can be used outside of a convergence run; a cookbook (attribute-validator) is available to perform validation during a chef run, at compile or converge time.

Versions:

  1. 0.9.0 - October 14, 2015 (26 KB)
  2. 0.8.0 - April 15, 2015 (25 KB)
  3. 0.7.0 - May 21, 2014 (26 KB)
  4. 0.6.1 - May 21, 2014 (24.5 KB)
  5. 0.6.0 - January 28, 2014 (23.5 KB)
Show all versions (12 total)

Runtime Dependencies (1):

  • chef >= 11.6
  • Development Dependencies (2):

  • bundler ~> 1.3
  • rake ~> 0.8
  • Owners:

    Authors:

    • Clinton Wolfe

    SHA 256 checksum:

    8c4c6ac361b238c4c7898a7d3338758eabc012d6e7214713c13eda95e4b80ded

    Total downloads 80,737

    For this version 45,349

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    BSD (3-clause)

    Required Ruby Version: >= 0

    Links: