RubyGems Navigation menu

commander-openflighthpc 2.2.0

The complete solution for Ruby command-line executables. Commander bridges the gap between other terminal related libraries you know and love (OptionParser, HighLine), while providing many new features, and an elegant API.

Versions:

  1. 2.2.0 - July 30, 2020 (16.5 KB)
  2. 2.1.2 - May 22, 2020 (16.5 KB)
  3. 2.1.1 - May 07, 2020 (16.5 KB)
  4. 2.1.0 - May 07, 2020 (16.5 KB)
  5. 2.0.2 - April 28, 2020 (29.5 KB)
Show all versions (13 total)

Runtime Dependencies (3):

  • highline > 1.7.2
  • paint ~> 2.1.0
  • slop ~> 4.8
  • Development Dependencies (4):

  • rake >= 0
  • rspec ~> 3.2
  • rubocop ~> 0.49.1
  • simplecov >= 0
  • Owners:

    Pushed by:

    Authors:

    • Alces Flight Ltd, TJ Holowaychuk, Gabriel Gilder

    SHA 256 checksum:

    258d561240632cb28cf807735a6589a1bc16317727e1e20af62cc2252375768c

    Total downloads 5,763

    For this version 298

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: