RubyGems Navigation menu

curses-extension 1.2

The Ruby curses library is sorely lacking some important features. This class extension adds a set of features that makes it much easier to create and manage terminal curses applications in Ruby. See the Github page for information on what properties and functions are included: https://github.com/isene/Ruby-Curses-Class-Extension. The curses_template.rb is also installed in the lib directory and serves as the basis for my own curses applications. New in 1.2: Added functions `print`, `puts`and `format`.

Versions:

  1. 1.2 - January 25, 2023 (7 KB)
  2. 1.1.4 - December 18, 2021 (6.5 KB)
  3. 1.1.3 - November 19, 2021 (6.5 KB)
  4. 1.1.2 - November 18, 2021 (6.5 KB)
  5. 1.1.1 - September 26, 2021 (6.5 KB)
Show all versions (6 total)

Runtime Dependencies (1):

curses ~> 1.3, >= 1.3.2

Owners:

Pushed by:

Authors:

  • Geir Isene

SHA 256 checksum:

1fd46daf0ae9e90256d7009fb32939123be46b707c2d18cfb01e46fc542ea9b2

Total downloads 5,404

For this version 147

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

Unlicense

Required Ruby Version: >= 0

Links: