RubyGems Navigation menu

erbook 9.2.1

ERBook 9.2.1 Write books, manuals, and documents in eRuby http://snk.tuxfamily.org/lib/erbook/ ERBook is an extensible document processor that emits [1]any document you can imagine from [2]eRuby templates, which allow scripting and dynamic content generation. Version 9.2.1 (2009-11-18) This release fixes some bugs in, and improves the readability and load time of, generated XHTML documents. Bug fixes * Prevent search button from starting search when search box untouched. * Prevent browser from fetching base-64 embedded URI sources by qualifying their digests with the "cid" URI schema, which is used to identify the parts of a multi-part e-mail message. This cuts down on the amount of "404 - File Not Found" errors on the web server which hosts your generated XHTML documents because web browsers will not confuse these embedded "cid" digests as being relative HTTP files. Housekeeping * Increase vertical spacing between [3]References for better readability. * Embed W3C validator badges as base-64 data URIs to reduce page load time. * Split the document processing code in ERBook::Document into smaller self-documenting methods. References 1. http://snk.tuxfamily.org/lib/erbook/#HelloWorld 2. http://en.wikipedia.org/wiki/ERuby 3. http://snk.tuxfamily.org/lib/erbook/#_references

Versions:

  1. 9.2.1 - November 19, 2009 (457 KB)
  2. 9.2.0 - November 07, 2009 (453 KB)
  3. 9.1.0 - November 03, 2009 (449 KB)
  4. 9.0.0 - October 19, 2009 (446 KB)
  5. 8.0.0 - October 11, 2009 (489 KB)
Show all versions (14 total)

Runtime Dependencies (7):

  • coderay >= 0.8
  • ember ~> 0
  • haml >= 2.2.2
  • inochi ~> 1
  • json >= 0
  • maruku ~> 0.5
  • mime-types >= 1.16
  • Development Dependencies (1):

    Owners:

    Authors:

    • Suraj N. Kurapati

    SHA 256 checksum:

    15ffb0651cefc2819ab58e1be8ed7c52717d432d9610a008caa200e8ee83f28d

    Total downloads 40,636

    For this version 3,903

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: None

    Links: