RubyGems Navigation menu

fit4ruby 3.10.0

This library can read and write FIT files and convert them into a Ruby data structure for easy processing. This library was written for Garmin devices like the FR620, Fenix 3, Fenix 3 HR, Fenix 5 (s and X). Fit files from other devices may work as well but have not been tested.

Versions:

  1. 3.10.0 - August 14, 2022 (63.5 KB)
  2. 3.9.0 - November 17, 2021 (62.5 KB)
  3. 3.8.0 - February 14, 2021 (62 KB)
  4. 3.7.0 - September 01, 2020 (59.5 KB)
  5. 3.6.0 - July 26, 2020 (59 KB)
Show all versions (36 total)

Runtime Dependencies (1):

  • bindata ~> 2.4.8
  • Development Dependencies (5):

  • bundler >= 1.6.4
  • pry >= 0.12
  • rake ~> 13.0.3
  • rspec >= 3.8
  • yard ~> 0.9.20
  • Owners:

    Pushed by:

    Authors:

    • Chris Schlaeger

    SHA 256 checksum:

    daae14357aef8c7d63c5f145a9db4d12921598499640b955bd3f0c8ce7623a02

    Total downloads 74,875

    For this version 474

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    GNU GPL version 2

    Required Ruby Version: >= 2.0

    Links: