RubyGems Navigation menu

github_api 0.14.1

Ruby client that supports all of the GitHub API methods. It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Client::Repos.new if working solely with repositories is your main concern. Intuitive query methods allow you easily call API endpoints.

Versions:

  1. 0.18.2 - November 19, 2017 (141 KB)
  2. 0.18.1 - October 07, 2017 (141 KB)
  3. 0.17.0 - April 18, 2017 (140 KB)
  4. 0.16.0 - April 02, 2017 (139 KB)
  5. 0.15.0 - March 25, 2017 (137 KB)
  6. 0.14.1 - June 21, 2016 (136 KB)
Show all versions (90 total)

Runtime Dependencies (5):

  • addressable ~> 2.4.0
  • descendants_tracker ~> 0.0.4
  • faraday < 0.10, ~> 0.8
  • hashie >= 3.4
  • oauth2 >= 0
  • Development Dependencies (2):

    Owners:

    Authors:

    • Piotr Murach

    SHA 256 checksum:

    ce6c52672c6fde38f6adae3210e418c28171dcf275ad6ad9741884320f4688ca

    Total downloads 2,831,097

    For this version 15,010

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.2

    Links: