RubyGems Navigation menu

github_api 0.5.2

Ruby wrapper that supports all of the GitHub API v3 methods(nearly 200). It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Repos.new if working solely with repositories is your main concern.

Versions:

  1. 0.18.2 - November 19, 2017 (141 KB)
  2. 0.18.1 - October 07, 2017 (141 KB)
  3. 0.17.0 - April 18, 2017 (140 KB)
  4. 0.16.0 - April 02, 2017 (139 KB)
  5. 0.15.0 - March 25, 2017 (137 KB)
  6. 0.5.2 - May 20, 2012 (179 KB)
Show all versions (90 total)

Runtime Dependencies (5):

  • faraday ~> 0.8.0
  • hashie ~> 1.2.0
  • multi_json ~> 1.3
  • nokogiri ~> 1.5.2
  • oauth2 ~> 0.7
  • Development Dependencies (11):

    Owners:

    Authors:

    • Piotr Murach

    SHA 256 checksum:

    2ba9c4b424b5b94c1564f54505aafa40dfd808cd74578bf1625c6e1214010c6b

    Total downloads 2,831,684

    For this version 2,894

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: None

    Links: