RubyGems Navigation menu

hyper-model 0.99.6

HyperModel gives your HyperComponents CRUD access to your ActiveRecord models on the client, using the the standard ActiveRecord API. HyperModel also implements push notifications (via a number of possible technologies) so changes to records on the server are dynamically updated on all authorised clients.

Versions:

  1. 1.0.alpha1.8 - April 13, 2021 (70.5 KB)
  2. 1.0.alpha1.7 - April 05, 2021 (70.5 KB)
  3. 1.0.alpha1.6 - March 29, 2021 (70.5 KB)
  4. 1.0.alpha1.5 - June 19, 2019 (68 KB)
  5. 1.0.alpha1.4 - February 16, 2019 (63 KB)
Show all versions (27 total)

Runtime Dependencies (4):

activerecord >= 4.0.0
hyper-component = 0.99.6
hyper-operation = 0.99.6

Development Dependencies (36):

bundler >= 0
capybara >= 0
libv8 ~> 6.7.0
mini_racer ~> 0.2.4
mysql2 >= 0
opal-browser ~> 0.2.0
opal-rails ~> 0.9.4
parser >= 0
pry >= 0
pry-rescue >= 0
puma >= 0
pusher >= 0
rails >= 4.0.0
rake >= 0
react-rails >= 2.4.0, < 2.5.0
rspec-its >= 0
rspec-steps ~> 2.1.1
rspec-wait >= 0
rubocop ~> 0.51.0
shoulda >= 0
sqlite3 >= 0
timecop ~> 0.8.1
unparser ~> 0.3.0

Owners:

Authors:

  • Mitch VanDuyn, Jan Biedermann

SHA 256 checksum:

84e0c5928115afb3cf3c2498d069e2f11c0030110576a85b1cdc51478928c3b9

Total downloads 28,975

For this version 1,774

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 0

Links: