RubyGems Navigation menu

hyperctl 0.1.1

This Gem provides a simple cli utility named `hyperctl` that can check the status of and [with appropriate permissions] enable/disable hyperthreading/SMT/sibling cores on Linux via the `sysfs` pseudo filesystem. It should be compatible with most modern Linux distributions as long as `sysfs` is mounted at `/sysfs`.

Versions:

  1. 0.1.1 - December 02, 2014 (11 KB)
  2. 0.1.0 - December 02, 2014 (10.5 KB)

Runtime Dependencies (1):

  • docopt ~> 0.5.0
  • Development Dependencies (7):

  • fakefs ~> 0.5.2
  • mocha ~> 1.0
  • rake ~> 10.0
  • rspec ~> 3.0
  • rspec-expectations ~> 3.0
  • rspec-mocks ~> 3.0
  • yard ~> 0.8
  • Owners:

    Authors:

    • Joshua Hoblitt

    SHA 256 checksum:

    1657c98fad08d92b40465f78f8efedc89fa97566a16e8ae2f16aafad97487505

    Total downloads 15,136

    For this version 13,760

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    Apache 2.0

    Required Ruby Version: >= 1.8.7

    Links: